Problem with connection

Discussion of the Generic Collectible Card Game engine designed and run by Tommi "wigy" Ronkainen.
Shadowblade
Posts: 1
Joined: Mon Jan 07, 2013 9:57 am

Problem with connection

Post by Shadowblade » Mon Jan 07, 2013 1:48 pm

Hi,

i´ve trying to start using GCCG, and after installing it following the post here:
http://www.councilofelrond.org/forum/vi ... f=20&t=903

i´ve experienced an error:

Conecting to gccg.councilofelrond.org port 29130
Server closed connection
ABNORMAL EXIT!

My METW bat looks like this:

@echo off
set HOME=C:
set USER=Windows
set CLIENT=.\ccg_client.exe
if exist .\home set HOME=.\home
if exist module_windows32\ccg_client.exe set CLIENT=module_windows32\ccg_client.exe
start %CLIENT% --server gccg.councilofelrond.org. --user %USER% %1 %2 %3 %4 %5 %6 %7 %8 %9 metw.xml

(i´ve edited it)

and the core weights 65.8 MB and metw 696 Mb

Thank you very much for your help!

User avatar
Thorsten the Traveller
Council Member
Posts: 1609
Joined: Tue Feb 06, 2007 1:44 pm
Location: Tilburg, Netherlands

Re: Problem with connection

Post by Thorsten the Traveller » Wed Jan 09, 2013 9:19 pm

same problem, had to reinstall gccg since all of a sudden I could not reconnect anymore (the whole option was unavailable).
after reinstalling, using the core metwDC.bat, the above message was given.
Stone-age did not end because man ran out of rocks.

Nknma
Posts: 134
Joined: Sat Aug 19, 2006 7:08 pm
Location: Tampere/Finland

Re: Problem with connection

Post by Nknma » Wed Jan 09, 2013 9:21 pm

Thorsten the Traveller wrote:same problem, had to reinstall gccg since all of a sudden I could not reconnect anymore (the whole option was unavailable).
after reinstalling, using the core metwDC.bat, the above message was given.
Captain Obvious here, but did you try 'right click' -> reconnect?

User avatar
Thorsten the Traveller
Council Member
Posts: 1609
Joined: Tue Feb 06, 2007 1:44 pm
Location: Tilburg, Netherlands

Re: Problem with connection

Post by Thorsten the Traveller » Wed Jan 09, 2013 9:24 pm

Admiral For Sure here: for sure :-)
Stone-age did not end because man ran out of rocks.

fisilva1
Posts: 13
Joined: Tue Mar 06, 2012 10:05 pm

Re: Problem with connection

Post by fisilva1 » Thu Jan 10, 2013 1:49 am

similar problem .

when I try to run the metw file the screen goes black. Nothing happen.

Delete all files, and then re-download the whole thing (700 mb), but still nothing....

anyone knows what is going on?

Felipe

Beornd
Posts: 168
Joined: Fri Feb 09, 2007 5:15 pm

Re: Problem with connection

Post by Beornd » Thu Jan 10, 2013 9:22 am

Perhaps the current core is broken reupdate to a previous version

http://www.councilofelrond.org/forum/vi ... =20&t=1998

fisilva1
Posts: 13
Joined: Tue Mar 06, 2012 10:05 pm

Re: Problem with connection

Post by fisilva1 » Thu Jan 10, 2013 8:53 pm

Nope, still broke.... already did a reverse-update to version 645 (supposedly working, according to a previous post), but still not working.
Just a dead black screen....

Any ideas?

Felipe

Vastor Peredhil
Council Member
Posts: 925
Joined: Wed Jan 31, 2007 10:46 am
Location: Kempen (Niederrhein) Germany

Re: Problem with connection

Post by Vastor Peredhil » Thu Jan 10, 2013 9:00 pm

see which of your system fles is corrupt in C/.GCCG

backup the whole thing , delete the folder and open a metw.bat within core, should let you set up a new user, that way decks and such can be save if you backthem up out of there 1st

fisilva1
Posts: 13
Joined: Tue Mar 06, 2012 10:05 pm

Re: Problem with connection

Post by fisilva1 » Thu Jan 10, 2013 11:12 pm

Found the broken file: a deck with 0 kb....

the system did not let me erase it, so I create a new account.
How can I retrieve my old account?

My user is fisilva

Thanks!

Felipe

User avatar
Thorsten the Traveller
Council Member
Posts: 1609
Joined: Tue Feb 06, 2007 1:44 pm
Location: Tilburg, Netherlands

Re: Problem with connection

Post by Thorsten the Traveller » Thu Jan 10, 2013 11:33 pm

...but I have reinstalled gccg completely (without adding my gccg files), done a complete new core checkout, started a new user, and still I cannot connect to the server.

connecting to gccg.councilofelrond.org port 29130
server closed connection!
abnormal exit!

basically the same message you get when server is down.
Stone-age did not end because man ran out of rocks.

Nknma
Posts: 134
Joined: Sat Aug 19, 2006 7:08 pm
Location: Tampere/Finland

Re: Problem with connection

Post by Nknma » Fri Jan 11, 2013 7:51 am

Shadowblade wrote:Hi,

i´ve trying to start using GCCG, and after installing it following the post here:
http://www.councilofelrond.org/forum/vi ... f=20&t=903

i´ve experienced an error:

Conecting to gccg.councilofelrond.org port 29130
Server closed connection
ABNORMAL EXIT!

My METW bat looks like this:

@echo off
set HOME=C:
set USER=Windows
set CLIENT=.\ccg_client.exe
if exist .\home set HOME=.\home
if exist module_windows32\ccg_client.exe set CLIENT=module_windows32\ccg_client.exe
start %CLIENT% --server gccg.councilofelrond.org. --user %USER% %1 %2 %3 %4 %5 %6 %7 %8 %9 metw.xml

(i´ve edited it)

and the core weights 65.8 MB and metw 696 Mb

Thank you very much for your help!
The last line of my metw.bat looks bit different than yours:
start %CLIENT% --design 1024x768 --user %USER% %1 %2 %3 %4 %5 %6 %7 %8 %9 metw.xml

User avatar
Thorsten the Traveller
Council Member
Posts: 1609
Joined: Tue Feb 06, 2007 1:44 pm
Location: Tilburg, Netherlands

Re: Problem with connection

Post by Thorsten the Traveller » Fri Jan 11, 2013 9:29 am

I'll look into that later today, but:
a) I had no problem logging in just half an hour earlier using the same .bat file
b) I use the most updated core file, if that's not correct then others should have the same problem
c) I even tried the .bat file sent by Nico, which works for him.

So I cannot see how this would be the problem.
Stone-age did not end because man ran out of rocks.

Beornd
Posts: 168
Joined: Fri Feb 09, 2007 5:15 pm

Re: Problem with connection

Post by Beornd » Fri Jan 11, 2013 10:12 am

I think you had the same problems like me a few months ago - the account had an incorrect file and so you can´t connect without help of josh - you mailed him?

http://www.councilofelrond.org/forum/vi ... =20&t=1998

I think buying cards doesn´t work and infects the accounts.

User avatar
Thorsten the Traveller
Council Member
Posts: 1609
Joined: Tue Feb 06, 2007 1:44 pm
Location: Tilburg, Netherlands

Re: Problem with connection

Post by Thorsten the Traveller » Fri Jan 11, 2013 8:00 pm

Yes Josh has restored an old copy of my account, and that seems to work.
not that I get it, because I couldn't enter with a new account either...
nor do we know what corrupts these accounts, that would be nice to know also.
Stone-age did not end because man ran out of rocks.

User avatar
Mordakai
Posts: 221
Joined: Fri Mar 01, 2013 10:38 am

Re: Problem with connection

Post by Mordakai » Sun Jan 03, 2016 10:09 pm

Hi there, I'm having problems with the connection these last days. I powered up my laptop, from which I played a lot until july without any issue, but now I cannot connect.

"connecting to gccg.councilofelrond.org on port 29130
connection failed
working offline"


Any ideas? I did not change anything, the computer just stayed off a few months, but that's all. I tried a SVN checkout, but problem persists.
C'mon, not the Elves of Lindon AGAIN...

Post Reply

Return to “GCCG”